Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 09, 2025 - 00:00 CDT
Scheduled
Expected Impact: Logix Fiber Networks will be performing essential internal maintenance in a Houston Core Network element. This maintenance, which includes software upgrades, is aimed at optimizing the stability and performance of our network infrastructure, mitigating the risk of unplanned outages, and ensuring continued service reliability.
Potential Disruptions: While Logix will make every effort to minimize disruption, customers should be aware that certain services, specifically Logix Internet and DIA (Dedicated Internet Access) services, may be impacted or experience temporary interruptions during the maintenance window.
Logix apologizes for any inconvenience this may cause and thanks customers for their patience and understanding as they work to enhance service quality.
Posted Jul 03, 2025 - 12:47 CDT
This scheduled maintenance affected: Data Centers (Logix Fiber Network).