Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 14, 2025 - 07:45 CDT
Scheduled
Critical Impact: During this maintenance, customers will experience a loss of redundancy. If your systems are connected to the specific UPS system undergoing maintenance and are not dual-powered, they will lose power during that period.
Maintenance Window
Start Date/Time (Local): July 14, 2025, at 7:50 AM
END Date/Time (Local): July 18, 2025, at 5:00 PM
Detailed Maintenance Schedule
Tuesday, July 15, 2025 Electrical teams will perform maintenance on the following UPS systems:
9:00 AM: Power down UDPAA110 and UDPAB110 9:10 AM: Power down UPSAA110, AB110, and AC110 9:20 AM: Power down MSBA0110 2:00 PM: Restore power to MSBA0110 2:30 PM: Restore power to UPSAA110, AB110, and AC110 3:00 PM: Restore power to UDPAA110 and UDPAB110 3:30 PM: Transfer all PDUs to UPS power Wednesday, July 16, 2025 Electrical teams will perform maintenance on the following UPS systems:
8:00 AM: Power down PDUs and RPPs fed from UDPB0110 8:10 AM: Power down UPSBA110 9:20 AM: Restore power to UPSBA110 9:40 AM: Restore power to PDUs and RPPs fed from UDPB0110 Friday, July 18, 2025
8:00 AM: Power down F system 2:30 PM: Restore F system to normal power 3:00 PM: Check all systems for normal operations and clear alarms. Testing Completion: 5-Year Breaker Testing will be completed after the final checks on July 18, 2025.
Action Required: Please review this schedule carefully and take necessary precautions if your equipment is single-powered or dependent on redundancy during these specific times.
Posted Jul 03, 2025 - 12:52 CDT
This scheduled maintenance affected: Data Centers (Houston - Data Center).